Plugin For Upgrading Apache Geronimo 2.1 to JPA 2.0

An Apache OpenJPA 2.0.0-beta plugin for Apache Geronimo 2.1 Server has been released.

This plugin allows Apache Geronimo 2.1 to be upgraded from JEE 5's JPA 1.0 to JEE 6's JPA 2.0, without upgrading to the full JEE 6 server. The JPA 2.0 is available through a set of plugins using the Apache OpenJPA 2.0.0 beta, which can be be installed on several Geronimo 2.1x servers: 2.1.3, 2.1.4, and 2.1.5-SNAPSHOT.

Please note that installing the OpenJPA2 plugins will replace the existing OpenJPA plugin. Full installation instructions can be found at the Apache Geronimo website.

jt

What do you think?

JAX Magazine - 2014 - 03 Exclucively for iPad users JAX Magazine on Android

Comments

Latest opinions