Rails and JavaFX Support

NetBeans IDE 6.9 Released with OSGi and CDI Support

NetBeans IDE 6.9 is finally here!

This release introduces support for Equinox, Spring Framework 3.0 library support, Rails 3.0 Beta, PHP Zend Framework and JSR-299, Contexts and Dependency Injection support. NetBeans IDE 6.9 also comes with JavaFX SDK 1.3 and a new JavaFX Composer for JavaFX development.

JDK 6 is now required for NetBeans launchers and installers, and the new project wizard introduces four new project archetypes for Maven projects - "Maven OSGi Bundle," "Maven NetBeans Module using OSGi," "Maven NetBeans Module," and "Maven NetBeans Application.”

NetBeans 6.9 is available in English, Brazilian Portuguese, Japanese and Simplified Chinese.

Please see the Release Notes for information.

Jessica Thornsby

What do you think?

JAX Magazine - 2014 - 03 Exclucively for iPad users JAX Magazine on Android

Comments

Latest opinions